Sentry Outage History
50 incidents reported. Data sourced from the official Sentry status page.
50
Total Incidents
7
Major/Critical
8
Minor
50
Resolved
January 2026
Investigating Issues with Dashboard
majorJan 29, 11:02 PM→Jan 29, 11:43 PMresolved
Jan 29, 11:43 PM
resolved — We have resolved the issue and all systems are working as expected.
Jan 29, 11:24 PM
monitoring — We have identified an issue related to database contention and have issued a fix. We are continuing to monitor the system as it returns to health.
Jan 29, 11:05 PM
investigating — We are investigating an issue where the Sentry Dashboard may be slow to load.
+1 more updates
Delay in span ingestion
noneJan 27, 02:51 PM→Jan 27, 06:56 PMresolved
Jan 27, 06:56 PM
resolved — Ingestion has recovered.
Jan 27, 06:03 PM
identified — The issue has been identified and a fix is being implemented.
Jan 27, 02:51 PM
investigating — We are investigating a delay in ingesting spans in the US region.
Crons ingestion backlogged
noneJan 23, 06:38 PM→Jan 24, 12:27 AMresolved
Jan 24, 12:27 AM
resolved — Backlog has been processed and crons should be running as normal
Jan 23, 09:46 PM
identified — The issue has been identified and we working through backlogs.
Jan 23, 06:38 PM
investigating — We are currently investigating this issue.
UI unavailable
noneJan 12, 03:30 PM→Jan 12, 05:56 PMresolved
Jan 12, 05:56 PM
resolved — This incident has been resolved.
Jan 12, 04:53 PM
monitoring — Our UI has recovered from intermittent availability issues due to an increase in load on our DB, the load has recovered and the UI shouldn't experience any further issues. We're continuing to monitor...
Jan 12, 04:10 PM
investigating — Our UI is unavailable again, we're investigating the issue.
+2 more updates
Ingestion delays for transactions in EU regions
noneJan 12, 01:33 PM→Jan 12, 03:16 PMresolved
Jan 12, 03:16 PM
resolved — All backlogs have been processed and no data was lost.
Jan 12, 02:21 PM
investigating — We are now ingesting recent transaction data again and are processing old data in the background.
Jan 12, 02:16 PM
investigating — We have implemented a fix and are monitoring the situation closely. No data has been lost.
+1 more updates
Processing delays for spans in US
minorJan 8, 08:47 PM→Jan 8, 10:21 PMresolved
Jan 8, 10:21 PM
resolved — This incident has been resolved.
Jan 8, 10:04 PM
monitoring — A fix has been implemented and we are processing the backlog that formed during the incident.
Jan 8, 09:46 PM
identified — We have identified the issue and a fix is being deployed.
+1 more updates
December 2025
Increased request timeouts and 50x errors across multiple API endpoints
noneDec 30, 04:15 PM→Dec 30, 08:04 PMresolved
Dec 30, 08:04 PM
resolved — The issue has been resolved, and services are operating normally.
Dec 30, 05:50 PM
monitoring — A fix has been implemented, and we are monitoring the results.
Dec 30, 04:15 PM
investigating — We are investigating increased request timeouts and 50x errors across multiple API endpoints that may be impacting service availability.
Database data corruption
majorDec 23, 12:42 AM→Dec 23, 02:46 AMresolved
Dec 23, 02:46 AM
resolved — We had a database corruption where new org creation, user sign-ups, new API Token generation, and new integrations made between 3:45PM and 5:00PM PST were affected and will need to be re-created. No o...
Dec 23, 01:51 AM
monitoring — We restored the impacted services to operational state, while investigating the full impact of the incident
Dec 23, 01:32 AM
monitoring — We are continuing to monitor for any further issues.
+4 more updates
Sentry Login Issues
noneDec 20, 05:14 AM→Dec 20, 08:34 AMresolved
Dec 20, 08:34 AM
resolved — This incident has been resolved.
Dec 20, 07:18 AM
monitoring — A fix has been implemented and we are monitoring the results.
Dec 20, 06:40 AM
identified — We have identified the cause of our current login issues and are working on a fix.
+2 more updates
UI was unavailable between 14:20 and 14:23 UTC
noneDec 18, 03:05 PM→Dec 18, 03:05 PMresolved
Dec 18, 03:05 PM
resolved — Our UI was unavailable between 14:20 UTC and 14:23 UTC due to a bad configuration change, we have reverted the change and service has been restored.
Ingestion delays in US
criticalDec 10, 07:18 PM→Dec 10, 10:43 PMresolved
Dec 10, 10:43 PM
resolved — This incident has been resolved.
Dec 10, 09:47 PM
monitoring — We're continuing to process the backlog of errors and transactions. New events will be processed in a timely fashion.
Dec 10, 08:40 PM
monitoring — We are continuing to work through backlogs in errors and transactions. Profiles, attachments and replays have recovered.
+4 more updates
Ingestion delays in US
noneDec 10, 10:38 PM→Dec 10, 10:38 PMresolved
Dec 10, 10:38 PM
resolved — All backlogged errors and transactions have been processed, and ingestion is fully functional.
Unavailability of Sentry Web UI
majorDec 4, 12:27 AM→Dec 4, 01:19 AMresolved
Dec 4, 01:19 AM
resolved — The issue has been resolved.
Dec 4, 01:06 AM
monitoring — The fix has been deployed and systems are returning to health. We are continuing to monitor the recovery.
Dec 4, 01:00 AM
identified — We have identified an issue related to networking configuration and are currently deploying a fix.
+1 more updates
Issues and Discover Page Outage
noneDec 3, 08:57 PM→Dec 3, 08:57 PMresolved
Dec 3, 08:57 PM
resolved — There was an outage of the issues page and discover feature between approximately 12:30 to 12:40pm PST. The issue has been resolved.
Our UI was unavailable between 12:01 pm - 12:06 pm UTC
noneDec 1, 12:00 PM→Dec 1, 12:00 PMresolved
Dec 1, 03:57 PM
resolved — Between 12:01 pm - 12:06 pm UTC our UI was unavailable, we have resolved the issue and apologize for any inconvenience this caused.
November 2025
Profile ingestion delayed
minorNov 30, 04:38 AM→Nov 30, 05:41 AMresolved
Nov 30, 05:41 AM
resolved — This incident has been resolved.
Nov 30, 04:38 AM
investigating — We are currently investigating delayed ingestion for Profiles
Profile ingestion delayed
minorNov 29, 12:52 PM→Nov 30, 12:03 AMresolved
Nov 30, 12:03 AM
resolved — All backlogs have been processed.
Nov 29, 06:29 PM
monitoring — A fix has been implemented and we're monitoring the backlog processing.
Nov 29, 04:03 PM
identified — We've identified resource constraints and are working towards resolving the issue.
+2 more updates
sentry.io is down
noneNov 29, 11:20 AM→Nov 29, 02:51 PMresolved
Nov 29, 02:51 PM
resolved — This incident has been resolved.
Nov 29, 12:34 PM
monitoring — We have restarted the affected component and the service is now operating normally. We're continuing to monitor and investigate the root cause.
Nov 29, 11:20 AM
investigating — We are currently investigating this issue.
Degraded Issues Search Performance in the US region
noneNov 17, 09:58 PM→Nov 18, 03:53 AMresolved
Nov 18, 03:53 AM
resolved — This incident has been resolved
Nov 18, 03:07 AM
monitoring — We implemented a fix and are monitoring
Nov 17, 09:58 PM
investigating — We are currently investigating an issue in our infrastructure that is causing degraded search performance on the issues page
Elevated API latency and rate limits
noneNov 13, 10:18 PM→Nov 14, 09:48 AMresolved
Nov 14, 09:48 AM
resolved — This incident has been resolved.
Nov 14, 09:20 AM
monitoring — We are continuing to monitor the situation. While recovery is in progress, some users may experience intermittent issues accessing the user interface.
Nov 13, 10:57 PM
monitoring — A fix has been implemented and we're monitoring the results
+1 more updates
US spans ingestion is delayed
majorNov 12, 04:52 PM→Nov 12, 06:11 PMresolved
Nov 12, 06:11 PM
resolved — This incident has been resolved.
Nov 12, 04:55 PM
investigating — We are continuing to investigate this issue.
Nov 12, 04:52 PM
investigating — We are currently investigating this issue.
Checkout page degraded
minorNov 6, 09:57 AM→Nov 6, 01:14 PMresolved
Nov 6, 01:14 PM
resolved — This incident has been resolved.
Nov 6, 12:30 PM
monitoring — A fix has been implemented and we are monitoring the results.
Nov 6, 10:42 AM
identified — The issue has been identified and we're deploying a fix.
+1 more updates
Webhooks Delayed in US
noneNov 5, 07:00 PM→Nov 5, 10:03 PMresolved
Nov 5, 10:03 PM
resolved — Webhooks latency has returned to normal levels.
Nov 5, 07:00 PM
identified — Currently we are experiencing delays in webhook sending for custom integrations in the US region.
October 2025
Ingestion delayed in US
noneOct 30, 03:49 PM→Oct 30, 07:15 PMresolved
Oct 30, 07:15 PM
resolved — Ingestion latency has returned to normal levels.
Oct 30, 05:47 PM
monitoring — The increased latency for ingestion of all events has been resolved, we're continuing to monitor.
Oct 30, 04:51 PM
investigating — We're continuing to investigate increased latency for ingestion of all event types in our US region.
+1 more updates
Delay in processing profiles in US
noneOct 30, 04:48 PM→Oct 30, 06:01 PMresolved
Oct 30, 06:01 PM
resolved — A fix has been implemented and all messages have been processed.
Oct 30, 04:48 PM
investigating — Ingesting and storing profiles in the US is delayed.
Login to Codecov via Sentry button degraded
noneOct 30, 01:39 PM→Oct 30, 02:16 PMresolved
Oct 30, 02:16 PM
resolved — This incident has been resolved.
Oct 30, 01:39 PM
investigating — We are currently investigating this issue.
Sentry APIs experiencing High Latency
noneOct 24, 05:14 PM→Oct 24, 05:37 PMresolved
Oct 24, 05:37 PM
resolved — We have identified the issue and put a mitigation in place. API latency has returned to normal levels.
Oct 24, 05:14 PM
investigating — We are currently investigating elevated API latency in the US region.
Uptime Monitors missing names
noneOct 23, 04:55 PM→Oct 23, 07:44 PMresolved
Oct 23, 07:44 PM
resolved — Uptime monitor names are now always correctly displayed.
Oct 23, 05:46 PM
identified — We've identified the issue and are deploying a fix.
Oct 23, 04:55 PM
investigating — We are currently investigating an issue where Uptime Monitors may be missing their name.
Error ingestion delayed in US
noneOct 20, 08:10 AM→Oct 20, 12:41 PMresolved
Oct 20, 12:41 PM
resolved — This incident has been resolved.
Oct 20, 12:40 PM
monitoring — We are continuing to monitor for any further issues.
Oct 20, 11:34 AM
monitoring — New events are being processed promptly, and we are continuing to process backlogged events.
+3 more updates
Span ingestion delayed in US
minorOct 17, 12:59 PM→Oct 17, 01:41 PMresolved
Oct 17, 01:41 PM
resolved — The backlog has been processed and latency is back to normal.
Oct 17, 01:16 PM
monitoring — A fix has been made, and we're continuing to monitor the backlog
Oct 17, 12:59 PM
investigating — We are investigating increased latency for span ingestion in the US region.
Span ingestion delayed in US
minorOct 15, 02:06 PM→Oct 15, 02:55 PMresolved
Oct 15, 02:55 PM
resolved — Backlogs have been processed and ingestion is no longer delayed.
Oct 15, 02:36 PM
monitoring — A fix has been deployed and we're making progress on the backlog.
Oct 15, 02:27 PM
identified — We've identified the source of the delay and have a fix in place.
+1 more updates
delayed for some subscription firing in errors us
noneOct 11, 09:59 PM→Oct 11, 10:20 PMresolved
Oct 11, 10:20 PM
resolved — The incident has been resolved.
Oct 11, 10:17 PM
monitoring — A fix has been implemented and we are monitoring the results
Oct 11, 09:59 PM
investigating — We are currently investigating
Ingestion delays for errors in US region
noneOct 5, 10:36 AM→Oct 5, 01:12 PMresolved
Oct 5, 01:12 PM
resolved — Ingestion backlog has been cleared.
Oct 5, 12:07 PM
monitoring — We have mitigated the issue and continue to monitor.
Oct 5, 11:31 AM
identified — The issue has been identified and new errors are being ingested without delays, we are currently processing backlogged errors.
+1 more updates
Incorrectly firing alerts with 'monitor.slug' conditions in US & EU
noneOct 2, 07:38 PM→Oct 2, 11:09 PMresolved
Oct 2, 11:09 PM
resolved — This incident has been resolved.
Oct 2, 07:57 PM
identified — The issue has been identified and a fix is being implemented.
Oct 2, 07:38 PM
investigating — We're currently investigating incorrectly firing alerts with 'monitor.slug' conditions in both our US and EU regions.
Ingestion delays for errors and transactions in US region
noneOct 1, 03:39 PM→Oct 1, 05:18 PMresolved
Oct 1, 05:18 PM
resolved — This incident is resolved.
Oct 1, 05:09 PM
monitoring — The source of latency has been identified and we're continuing to monitor the backlog as it processes.
Oct 1, 03:39 PM
investigating — We are currently investigating this issue.
September 2025
Seer Features erroring intermittently
noneSep 29, 06:31 PM→Sep 29, 07:01 PMresolved
Sep 29, 07:01 PM
resolved — Gemini-powered Seer features seem to be working normally.
Sep 29, 06:31 PM
investigating — Google Gemini-powered features such as Seer Issue Fix, Issue Summary/Issue Scan, and Replay Summary will currently intermittently fail.
This seems to happen regardless of region.
Errors performance, ingestion degraded
noneSep 26, 09:22 AM→Sep 26, 09:31 PMresolved
Sep 26, 09:31 PM
resolved — This incident has been resolved.
Sep 26, 03:53 PM
monitoring — We have mitigated the issue, ingestion and API response is back to normal.
Sep 26, 02:40 PM
identified — We have mitigated the issue, ingestion and API response is back to normal.
+4 more updates
Analytics Ingestion delayed in DE region
noneSep 24, 11:35 PM→Sep 25, 01:17 AMresolved
Sep 25, 01:17 AM
resolved — Systems are operating normally once more.
Sep 25, 01:06 AM
monitoring — Fix was implemented, transactions ingestion is not delayed anymore. We are monitoring the situation.
Sep 25, 12:59 AM
identified — The issue with transactions ingestion has been identified and a fix is being implemented.
+3 more updates
Error ingestion delays in US region
noneSep 24, 02:46 PM→Sep 24, 08:58 PMresolved
Sep 24, 08:58 PM
resolved — All backlogged errors are processed. Error ingestion is back to operational.
Sep 24, 08:08 PM
identified — We are continuing to process backlogged errors, new errors are being ingested without delays.
Sep 24, 07:01 PM
identified — We are continuing to process backlogged errors, new errors are being ingested without delays.
+4 more updates
Error ingestion delay in US
criticalSep 23, 10:25 PM→Sep 24, 12:17 AMresolved
Sep 24, 12:17 AM
resolved — All backlog is burnt down. Error ingestion is back to operational.
Sep 24, 12:15 AM
monitoring — New errors will not experience delays anymore. However for older errors that were sent during this incident, we are still processing the backlog
Sep 23, 10:54 PM
identified — The fix will take some time to get rolled out. We are monitoring
+3 more updates
[US] Attachments ingestion is delayed
majorSep 23, 11:15 PM→Sep 24, 12:03 AMresolved
Sep 24, 12:03 AM
resolved — Attachment ingestion is no longer delayed
Sep 23, 11:24 PM
investigating — We are continuing to investigate this issue.
Sep 23, 11:24 PM
investigating — This is a side effect of the errors ingestion being delayed.
+2 more updates
Errors, transactions, and profiles ingestion delayed in US region
noneSep 16, 04:12 AM→Sep 16, 06:06 AMresolved
Sep 16, 06:06 AM
resolved — This incident has been resolved.
Sep 16, 04:37 AM
identified — We are now processing recent data again, and are recovering from our backlog concurrently.
Sep 16, 04:23 AM
identified — An issue with the backpressure mechanism has been identified. We are currently working on a fix.
+1 more updates
Delay in email notifications
noneSep 13, 12:52 PM→Sep 13, 01:08 PMresolved
Sep 13, 01:08 PM
resolved — This incident has been resolved.
Sep 13, 12:52 PM
identified — Email notifications related to issue workflow are currently delayed in the EU region
Delay in EU-region spans and logs ingestion
noneSep 10, 07:29 PM→Sep 10, 09:08 PMresolved
Sep 10, 09:08 PM
resolved — Spans and logs ingestion latency is back to normal.
Sep 10, 08:52 PM
monitoring — The fix is fully rolled out and we are seeing recovery in ingestion backlog and latency.
Sep 10, 08:34 PM
monitoring — The fix roll-out is still in-progress; we are continuing to monitor.
+3 more updates
Delayed issue ingestion in the US region
noneSep 9, 03:47 PM→Sep 9, 07:00 PMresolved
Sep 9, 07:00 PM
resolved — This incident has been resolved.
Sep 9, 04:16 PM
monitoring — All backlogs have been processed.
Sep 9, 03:47 PM
identified — The issue has been identified and a fix is being implemented.
[US] Transactions ingestion is delayed
minorSep 8, 05:32 PM→Sep 8, 08:00 PMresolved
Sep 8, 08:00 PM
resolved — All old transactions have been processed.
Sep 8, 06:04 PM
investigating — Cause was identified and mitigation in progress
Sep 8, 06:03 PM
investigating — We are backfilling older transactions while any new transactions coming in would be processed right away
+2 more updates
All old transactions have been processed.
noneSep 8, 07:54 PM→Sep 8, 07:54 PMresolved
Sep 8, 07:54 PM
resolved — All old transactions have been processed.
Delays in spike protection enforcement
noneSep 3, 03:15 PM→Sep 4, 03:33 PMresolved
Sep 4, 03:33 PM
resolved — Spike protection in our US region would have experienced delays up to 10 minutes, the root cause has now been addressed and these delays have been resolved.
Sep 3, 03:15 PM
identified — Starting at 6 AM PDT we are experiencing delays in spike protection enforcement in US.
August 2025
Sentry.io Dashboard Failing to Load
noneAug 26, 06:59 PM→Aug 26, 08:12 PMresolved
Aug 26, 08:12 PM
resolved — This incident has been resolved.
Aug 26, 07:20 PM
investigating — Alert latency has resolved to nominal levels. We are still investigating the root cause of the incident.
Aug 26, 07:19 PM
investigating — Dashboard loading failures have subsided. We are still investigating downstream problems with alert execution latency.
+2 more updates
Increased Latency on Transactions in EU Region
minorAug 26, 11:45 AM→Aug 26, 12:05 PMresolved
Aug 26, 12:05 PM
resolved — The increased latency for transactions in our EU region has recovered.
Aug 26, 11:45 AM
identified — We have identified an issue causing latency of up to 10 minutes on transaction ingestion in our EU region and are working on a fix.
Related Incident Histories
Get Sentry Outage Alerts
Be the first to know when Sentry go down.